5 一路安装一路心酸

本人一直在做.net 开发,由于客户指定要使用shopxo,对php来说,我是小白,从开始搭建环境开始,问题一波一波。终于在本地通过iis+php5/7+mysql使shopxo运行起来了。上传到云主机上,问题又一个一个的出现,现在一个问题已经困扰了两天了,特来求救。

Parse error: syntax error, unexpected '.', expecting '&' or variable (T_VARIABLE) in D:\wwwroot\anco\thinkphp\library\think\Loader.php on line 391

现在phpMyadmin是可以运行的,就是shopxo不行。所有的权限都给出,administrator也给了,还是不行。




请先 登录 后评论

最佳答案 2019-12-20 16:48

PHP 版本太低

请先 登录 后评论

其它 3 个回答

admin
擅长:ShopXO,PHP,服务器,前端

建议先参考一下安装教程

https://ask.shopxo.net/article/5

或者使用西部数码虚拟机或者宝塔面板一键安装

https://ask.shopxo.net/article/58

http://ask.shopxo.net/article/59


请先 登录 后评论
风车车
擅长:PHP

PHP 版本搞5.6或者更高

请先 登录 后评论
穆尹飞 - 科技数码
擅长:电脑,手机

请先 登录 后评论
  • 3 关注
  • 0 收藏,475 浏览
  • 光光 提出于 2019-08-31 11:38

相似问题